Wednesday, September 10, 2008

"OPSF Hub-And-Spoke And Virtual Links" lab - Issue Resolved

In response to yesterday's post: here
I have resolved the issue.

NOTE: Unused interfaces and other portions of the config are omitted.

Ok, so I went back to basics borrowing from this config, I configured R4 and R5 based off of:

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080094057.shtml#conf1

Modified Configs:
Router 4

host R4
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Serial0/1
ip address 1.1.1.4 255.255.255.0
clock rate 64000
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

Router 5

host R5
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Serial0/1
ip address 1.1.1.5 255.255.255.0
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

Here, the main difference is that I used HDLC between R4 and R5 versus Frame-Relay. I am able to establish an adjacency between
the two:

R4#sh int Serial0/1
Serial0/1 is up, line protocol is up
Hardware is PowerQUICC Serial
Internet address is 1.1.1.4/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set


R4#sh ip os ne

Neighbor ID Pri State Dead Time Address Interface
5.5.5.5 0 FULL/ - 00:00:34 1.1.1.5 Serial0/1
R4#sh ip os int s0/1
Serial0/1 is up, line protocol is up
Internet Address 1.1.1.4/24, Area 0
Process ID 1, Router ID 4.4.4.4, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 5.5.5.5
Suppress hello for 0 neighbor(s)
R4#




R5#sh int s0/1
Serial0/1 is up, line protocol is up
Hardware is PowerQUICC Serial
Internet address is 1.1.1.5/24
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
R5#sh ip os ne

Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 0 FULL/ - 00:00:37 1.1.1.4 Serial0/1
R5#
R5#sh ip os int s0/1
Serial0/1 is up, line protocol is up
Internet Address 1.1.1.5/24, Area 0
Process ID 1, Router ID 5.5.5.5, Network Type POINT_TO_POINT, Cost: 781
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:08
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 4.4.4.4
Suppress hello for 0 neighbor(s)
R5#


=================================================================================

I reconfigured R4 and R5 to reflect HDLC along with the lab book's info:

Router 4
!
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 172.12.23.4 255.255.255.0
shutdown
speed auto
half-duplex
!
interface Serial0/0
ip address 172.12.123.4 255.255.255.0
encapsulation frame-relay IETF
ip ospf hello-interval 5
ip ospf priority 0
no fair-queue
frame-relay map ip 172.12.123.2 321
frame-relay interface-dlci 321
frame-relay lmi-type cisco
!
!
interface Serial0/1
ip address 10.2.2.4 255.255.255.0
clock rate 64000
!
router ospf 1
router-id 44.44.44.44
log-adjacency-changes
area 45 virtual-link 5.5.5.5
network 4.4.4.4 0.0.0.0 area 4
network 10.2.2.0 0.0.0.255 area 45
network 172.12.123.0 0.0.0.255 area 0
!
!

Router 5
!
!
interface Loopback5
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 172.12.23.5 255.255.255.0
shutdown
speed auto
half-duplex
!
interface Serial0/1
ip address 10.2.2.5 255.255.255.0
!
router ospf 1
log-adjacency-changes
area 45 virtual-link 44.44.44.44
network 5.5.5.5 0.0.0.0 area 5
network 10.2.2.0 0.0.0.255 area 45
!
!

The adjacency is established:

R4#sh ip osp ne

Neighbor ID Pri State Dead Time Address Interface
5.5.5.5 0 FULL/ - 00:00:35 10.2.2.5 Serial0/1
R4#sh ip os int s0/1
Serial0/1 is up, line protocol is up
Internet Address 10.2.2.4/24, Area 45
Process ID 1, Router ID 44.44.44.44, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:02
Supports Link-local Signaling (LLS)
Index 1/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 5.5.5.5
Suppress hello for 0 neighbor(s)
R4#



R5#sh ip os ne

Neighbor ID Pri State Dead Time Address Interface
44.44.44.44 0 FULL/ - 00:00:33 10.2.2.4 Serial0/1
R5#sh ip os int s0/1
Serial0/1 is up, line protocol is up
Internet Address 10.2.2.5/24, Area 45
Process ID 1, Router ID 5.5.5.5, Network Type POINT_TO_POINT, Cost: 781
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:08
Supports Link-local Signaling (LLS)
Index 1/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 44.44.44.44
Suppress hello for 0 neighbor(s)
R5#


And thanks to the virtual link, I can now ping back to the hub router (R1).

R5#p 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/93/96 ms
R5#

R5#sh ip ro os
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/846] via 10.2.2.4, 00:03:03, Serial0/1
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/846] via 10.2.2.4, 00:03:03, Serial0/1
4.0.0.0/32 is subnetted, 1 subnets
O IA 4.4.4.4 [110/782] via 10.2.2.4, 00:03:03, Serial0/1
172.12.0.0/24 is subnetted, 1 subnets
O 172.12.123.0 [110/845] via 10.2.2.4, 00:03:03, Serial0/1
R5#


Now, I know Frame-Relay point-to-point is possible. This link proves it:
http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080094054.shtml#conf

I think my mistake with Frame-Relay OSPF Point-to-Point is that I should have
established a point-to-point sub-interface, e.g. interface Serial0.1 point-to-point
versus making R4 a frame-switch just to deal with point-to-point connectivity between
R4 and R5. O_o ??

Could be another reason, but I got frame-relay p2p to work as well. Check it out below:

Configs (then results after):

Router 4

!
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 172.12.23.4 255.255.255.0
shutdown
speed auto
half-duplex
!
interface Serial0/0
ip address 172.12.123.4 255.255.255.0
encapsulation frame-relay IETF
ip ospf hello-interval 5
ip ospf priority 0
no fair-queue
frame-relay map ip 172.12.123.2 321
frame-relay interface-dlci 321
frame-relay lmi-type cisco
!

interface Serial0/1
no ip address
encapsulation frame-relay
no keepalive
clock rate 64000
!
interface Serial0/1.1 point-to-point
ip address 10.2.2.4 255.255.255.0
frame-relay interface-dlci 444
!
router ospf 1
router-id 44.44.44.44
log-adjacency-changes
area 45 virtual-link 5.5.5.5
network 4.4.4.4 0.0.0.0 area 4
network 10.2.2.0 0.0.0.255 area 45
network 172.12.123.0 0.0.0.255 area 0
!


Router 5

!
!
interface Loopback5
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 172.12.23.5 255.255.255.0
shutdown
speed auto
half-duplex
!
!
interface Serial0/1
no ip address
encapsulation frame-relay
no keepalive
!
interface Serial0/1.1 point-to-point
ip address 10.2.2.5 255.255.255.0
frame-relay interface-dlci 444
!
router ospf 1
log-adjacency-changes
area 45 virtual-link 44.44.44.44
network 5.5.5.5 0.0.0.0 area 5
network 10.2.2.0 0.0.0.255 area 45
!
!


R4#sh ip os ne

Neighbor ID Pri State Dead Time Address Interface
5.5.5.5 0 FULL/ - 00:00:31 10.2.2.5 Serial0/1.1
R4#sh ip os int s0/1
%OSPF: OSPF not enabled on Serial0/1
R4#sh ip os int s0/1.1
Serial0/1.1 is up, line protocol is up
Internet Address 10.2.2.4/24, Area 45
Process ID 1, Router ID 44.44.44.44, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Index 1/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 5.5.5.5
Suppress hello for 0 neighbor(s)
R4#



R5#
R5#sh ip os ne

Neighbor ID Pri State Dead Time Address Interface
44.44.44.44 0 FULL/ - 00:00:32 10.2.2.4 Serial0/1.1
R5#sh ip os int s0/1.1
Serial0/1.1 is up, line protocol is up
Internet Address 10.2.2.5/24, Area 45
Process ID 1, Router ID 5.5.5.5, Network Type POINT_TO_POINT, Cost: 781
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:05
Supports Link-local Signaling (LLS)
Index 1/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 44.44.44.44
Suppress hello for 0 neighbor(s)
R5#
R5#



And last, but not least, pinging from R1 using TCL to all Loopbacks.

R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#1.1.1.1
+>(tcl)#2.2.2.2
+>(tcl)#4.4.4.4
+>(tcl)#5.5.5.5
+>(tcl)#} { ping $address re 3 si 100 }

Type escape sequence to abort.
Sending 3, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!
Success rate is 100 percent (3/3), round-trip min/avg/max = 1/3/4 ms
Type escape sequence to abort.
Sending 3, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!
Success rate is 100 percent (3/3), round-trip min/avg/max = 64/66/68 ms
Type escape sequence to abort.
Sending 3, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!
Success rate is 100 percent (3/3), round-trip min/avg/max = 64/65/68 ms
Type escape sequence to abort.
Sending 3, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!
Success rate is 100 percent (3/3), round-trip min/avg/max = 92/92/92 ms
R1(tcl)#^Z
R1#
05:09:33: %SYS-5-CONFIG_I: Configured from console by console
R1#

Thanks!

No comments:

Post a Comment